Conecta con nosotros

Noticias

El agujero en Linux GHOST, también afecta a WordPress y PHP

Publicado el

GHOST

GHOST

Investigadores de seguridad han descubierto que el agujero en Linux GHOST, también afecta a aplicaciones PHP, incluyendo el Sistema de Gestión de Contenidos (CMS), WordPress, utilizado en millones de sitios web.

MS Recomienda

Estudio sobre ciberseguridad en la empresa española ¡Participa en nuestra encuesta y gana!
Estudio "La virtualización en las empresas españolas" ¡Descárgate el informe!
Gestiona los dispositivos de tu empresa de forma inteligente Leer

GHOST, acrónimo de ‘glibc gethostbyname buffer overflow’ es un agujero crítico de Linux que afecta al GNU C Library conocido como glibc y que permite a un atacante tomar el control de los sistemas sin necesidad de conocer usuario o contraseña.

Este fallo de seguridad se puede explotar a través del gethostbyname de glibc, una función que utilizan casi todos los ordenadores Linux que está conectados en red, cuando un nodo está llamando a otro utilizando el archivo /etc/hosts o mediante DNS. Lo único que necesita hacer el atacante es provocar un desbordamiento de memoria utilizando un nombre de host inválido sobre el servicio de DNS.

La curiosidad de este vulnerabilidad crítica que ha salido a la luz esta semana, es que estaba presente en Linux desde el año 2000 y fue parcheada parcialmente en 2013. Sin embargo, la corrección no se marcó como de seguridad, por lo que distribuciones de largo recorrido como Debian 7, Red Hat y CentOS 5, 6 y 7 y Ubuntu LTS 12.04 y 10.04 no aplicaron el parche.

Aunque el error data de hace años, los responsables de las distribuciones han actuado en tiempo récord y un día después de conocerse la problemática de este GHOST comenzaron a publicar versiones parcheadas. Vulnerabilidades hay (y habrá) en todo tipo de software y sistemas operativos pero es justo reconocer que las del sistema libre se parchean de forman inmediata.

Una prueba para comprobar si un servidor Linux es vulnerable es ejecutar desde el terminal el siguiente fragmento de código comprobando si devuelve un error de segmentación: php -r ‘$e=»0″;for($i=0;$i<2500;$i++){$e=»0$e»;} gethostbyname($e);’ Segmentation fault

No se conoce si esta vulnerabilidad que afecta a todas las versiones de glibc-2.17 o inferior ha llegado a ser explotada, pero se recomienda parchear sistemas a la mayor brevedad, seguido de un reinicio del sistema.

 

Coordino el contenido editorial de MC. Colaboro en medios profesionales de TPNET: MCPRO, MuySeguridad, MuyCanal y Movilidad Profesional.

Lo más leído